Home
The Toolkit for Online Communities
17315 Community Members, 0 members online, 1885 visitors today
Log In Register
OpenACS Home : Forums : .LRN Q&A : Debian package of .LRN

Forum .LRN Q&A: Debian package of .LRN

Icon of envelope Request notifications

Collapse
Posted by Rocael Hernández Rizzardini on
Hello All,
we are happy to announce the *alpha* version of the debian package for .LRN:
download it here:
http://home.galileo.edu/~solca/dotlrn/

If you wanna use it with apt-get ;o), add this to /etc/apt/sources.list:
deb http://home.galileo.edu/~solca/dotlrn/binary/
deb-src http://home.galileo.edu/~solca/dotlrn/source/

In the future you'll be able to do it from here:
deb http://aptproxy.galileo.edu:9999/dotlrn/binary/
deb-src http://aptproxy.galileo.edu:9999/dotlrn/source/

(but the newer ones are now at ~solca)

For installing use: aptitude or `apt-get install dotlrn`
both after doing an `apt-get update`.

Start/Stop it as any other debian service: /etc/init.d/dotlrn

Things to fix yet:

*do not modify permissions for postgres in order to make a connection, needs to edit /var/lib/postgres/data/pg_hba.conf and put 'trust' instead of 'ident sameuser', to allow local connections.
* when you install, just press enter, enter ... since that initial configuration is not yet ready, soon will be.

It supports only PG, but so far its not possible for oracle anyway.

Please test it, and give feedback through this thread.

The author of the package is one of our hackers, Otto Solares (solca@galileo.edu). He followed all the conventions for debian packages, so this is a good candidate to become part of the official debian distribution.
This package has been done at Galileo University, as part of the E-LANE project.

Further adaption to make it just for oacs will be easy.

Enjoy!!!

Collapse
2: Re: Debian package of .LRN (response to 1)
Posted by Joel Aufrecht on
Fantastic.  Will try it out ASAP.
Collapse
3: Re: Debian package of .LRN (response to 1)
Posted by Luigi Martini on
I added a line:

deb http://home.galileo.edu/~solca/dotlrn/binary/

to /etc/apt/sources.list and then:

root@kirpibox:/home/luigi# apt-get update
E: Malformed line 17 in source list /etc/apt/sources.list (dist)

It did not like this line, maybe?
Collapse
4: Re: Debian package of .LRN (response to 3)
Posted by Otto Solares on
the correct line is:

deb http://home.galileo.edu/~solca/dotlrn/ binary/

-otto

Collapse
5: Re: Debian package of .LRN (response to 1)
Posted by Otto Solares on
Version 2 of the dotlrn package is ready for testing,
it fixes a lot of problems, as usual, add the following
entries to your /etc/apt/source.list:

deb http://home.galileo.edu/~solca/dotlrn/ binary/
deb-src http://home.galileo.edu/~solca/dotlrn/ source/

remember to `apt-get update` first.

Thanks for the feedback.

Collapse
6: Re: Debian package of .LRN (response to 1)
Posted by Luigi Martini on
root@kirpibox:/home/luigi# apt-get install dotlrn
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

Sorry, but the following packages have unmet dependencies:
  dotlrn: Depends: aolserver4 (>= 4.0) but it is not installable
          Depends: aolserver4-nscache (>= 1.4) but it is not installable
          Depends: aolserver4-nsopenssl (>= 3.0beta12) but it is not going to be installed
          Depends: aolserver4-nssha1 (>= 0.1) but it is not going to be installed
          Depends: aolserver4-nspostgres (>= 4.0) but it is not going to be installed
          Depends: aolserver4-nsldap (>= 0.0r8) but it is not going to be installed
          Depends: tdom (>= 0.7.8) but it is not installable
          Depends: postgresql-client (>= 7.4) but it is not going to be installed
E: Sorry, broken packages
Too many information: where should I start from, please?
Collapse
7: Re: Debian package of .LRN (response to 6)
Posted by Otto Solares on
Are you running debian sid?  The dependencies for dotlrn exists in sid only.
Collapse
8: Re: Debian package of .LRN (response to 1)
Posted by Luigi Martini on
I am running woody.
Do I need to do something before installing this package?
Do I have to follow OpenACS Installation documentation up to a certain point?
Collapse
9: Re: Debian package of .LRN (response to 8)
Posted by Otto Solares on
This package simply will not work for woody.  Probably you can follow the .LRN installation instructions.  It should work for debian sarge but i have not tested so far.
Collapse
Posted by Mischa Schaub on
Dear and clever people

As a first time user I installed on a fast PC a new SID. Then I added the dotlrn lines to the source.list and did everything needed with update and install.

All dependencies seemed to be fine. Perfect.

Then I was guided by some automatic setup file and things started to get wrong. The whole process did seem to finish fine, but when I wanted to do the changes described to /var/lib/postgres/data/pg_hba.conf there was no data folder in /var/lib/postgres/. As aolserver was not running either, I did a "apt-get remove" of dotlrn, aolserver, postgres, then I did a apt-get clean and installed everything again, in the hope, of arriving at the menu where things got all wrong the first time.

But now everything did install without showing the menu again. And there is still no postgres in /usr/local. So please, what should I do?

I would be awfully glad about your support. We would love to test dotlrn in our institution and I was so glad about that (theoretically) simple possibility of a debian package installation.

Kind  regards

Mischa

Collapse
Posted by Otto Solares on
Debian will not remove configuration files if you don't purge
the packages.  If you need to reconfigure dotlrn:

dpkg-reconfigure dotlrn

Too, dotlrn suggests the postgresql package but it doesn't enforce it as a dependency so you can have a different box running the postgres server.

A simple setup with dotlrn and postgres in the same box:

apt-get install dotlrn postgresql

When asked in the dotlrn package setup, the defaults will make it work with a local postgresql server.

Collapse
Posted by Mischa Schaub on
Thanx very much for your quick and helpful reaction.
I am approaching slowly: When I try to follow your instruction:

"*create the plpgsql language in the dotlrn databases, than can be done issuing this commmand as root in your database server:
su - postgres -s /bin/sh -c "createlang  plpgsql dotlrn",

then I get following error: "createlang: could not connect to database dotlrn: FATAL: database "dotlrn" does not exist"

Any help as always highly welcome

Mischa

Collapse
Posted by Mischa Schaub on
Mea culpa: Sorry about my last and stupid question. Just had to createdb dotlrn.

Would be nice to be able to withdraw such a silly statement from public visibility...  Mischa

Collapse
Posted by Carl Robert Blesius on
No silliness here. Posting it for public visibility prevents the next person from going through the same thing and having to ask the same question. Thanks Mischa.
Collapse
Posted by Mischa Schaub on
So here I am back again; everything seems to be installed, aolserver running, postgres running, but still on http://localhost:8000 I just find an adapted version of the aolserver welcomepage, not the dotlrn installation page. Any good ideas would be helpful

Sorry about bothering you again - often it's the easy things which seem of the highest difficulty...

Mischa

Collapse
Posted by Otto Solares on
Mischa, this dotlrn package creates the database, the only thing you must perform manually is the createlang step.

I'm pretty sure you are hitting the openacs pages, probably the dotlrn package is not fully installed/configured.

If you need step-by-step help drop me a mail, I could assist you via irc/im.

Collapse
17: Re: Redirecting problem (response to 1)
Posted by Zakaria Saja on
I finally able to install dotlrn using your debian package.

First I must edit /etc/init.d/dotlrn from the line:

DAEMON=/usr/sbin/aolserver4-nsd
to:
DAEMON=/usr/sbin/nsd

Then I try to run it again: /etc/init.d/dotlrn start

I point my browser to http://localhost:8000 and I get installation page. I filled it then proceed to installation. It creates the database and said it restart the dotlrn. So I do /etc/init.d/dotlrn start again.

But when I point my browser to http://localhost:8000 I get error. After trying with lynx I find out that:

  1. It send a cookie ad_s which I allow
  2. then redirect to http://localhost:8000/dotlrn/index
  3. then redirect to http://localhost:8000/register/?return%5furl=http%3a%2f%2flocalhost%3a8000%2fdotlrn%2findex
  4. then redirect to https://localhost:8000:8443/register/?return%5furl=http%3a%2f%2flocalhost%3a8000%2fdotlrn%2findex

There must be something very wrong because it try to redirect to localhost:8000:8443

Here my system details

Linux zakbox 2.6.6-1-686 #1 Wed May 12 14:57:57 EST 2004 i686 GNU/Linux
Debian Sarge/Testing
dotlrn                 2.0.3-2
aolserver4             4.0.5-1
aolserver4-doc         4.0.5-1
aolserver4-nscache     1.5-1
aolserver4-nsldap      0.0.r8-1
aolserver4-nsopenssl   3.0beta12-2
aolserver4-nspostgres  4.0-1
aolserver4-nssha1      0.1-1
postgresql             7.4.2-4

Currently I'm able to workaround the problem by commenting line ns_param nsopenssl from /etc/aolserver4/dotlrn.tcl. Is there more permanent fix, so I could use SSL?

Collapse
18: Re: Redirecting problem (response to 17)
Posted by Jade Rubick on
Zakaria, this is a problem I just fixed on OpenACS. I'm sure it hasn't been reflected in the dotlrn package yet.

Here's the post where I reported the same problem:
http://openacs.org/forums/message-view?message_id=194108

The fixes are in CVS. You can browse CVS via http://cvs.openacs.org

You will not have this problem is you change your installation to use the standard ports of 80 and 443. So you can either change the ports, or change your local installation with these fixes. Or you can wait until the package itself it updated.

Collapse
Posted by Eric Van Buggenhaut on
Hi,

Nice to have a debian package for this software !

I was just wondering.

Your package depends on the 'official' debian package of aolserver. But OpenACS relies on a patched version of aolserver, ie it needs

- the patch that makes ns_uuencode  work for binary files

- the patch that makes AOLserver respect the -g flag

How did you get around this ?

Also you might Suggests: libpam-radius-auth

Cheers,

Eric
ericvb@debian.org

Collapse
Posted by Otto Solares on
I don't have plans to provide an aolserver4 package, but if somebody contribute it I would integrate it as a dependency for our dotlrn packages for the next upstream version.
Collapse
Posted by Eduardo Pérez on
> Your package depends on the 'official' debian package of
> aolserver. But OpenACS relies on a patched version of
> aolserver, ie it needs
>
> - the patch that makes ns_uuencode work for binary files
>
> - the patch that makes AOLserver respect the -g flag

Could you add references to these patches?
Shouldn't they be in the Debian package anyway?
If they are not it's time to submit bugs and patches to the Debian maintainer.

Collapse
Posted by Talli Somekh on
There is an aolserver package in debian, at least in unstable. If that could be targeted it would really rock.

talli

Collapse
Posted by Eduardo Pérez on
That patches that Eric commented were for aolserver-3.x so they are not needed in the aolserver4 Debian package.

I've been using the Debian package of aolserver4 (aolserver4, aolserver4-nscache, aolserver4-nsopenssl, aolserver4-nspostgres and aolserver4-nssha1) for more than two months both in production and development with success, so please try it and report any problems to the Debian bug tracking system.

Collapse
Posted by Patrick Rebscher on
Hello,

i really appreciate your work !
Unfortunally i do have a problem:

I have installed the package with
apt-get install dotlrn postgres
I used the default values.

Then i modified the file
/etc/init.d/dotlrn
DAEMON=/usr/sbin/aolserver4-nsd


I changed the used ports to
80, 443 because of the Post from Jade Rubick. I then changed the aolserver4 ports to 8000 8443.

I could configure the package in the browser (i use lynx on the local console), after that the server wasn't reachable again. I also tried some restarts of the db and the server.

You can see this situation in my Error-Picture

I then tried to change the entries in
/var/lib/postgres/data/pg_hba.conf
to trust, but that didn't help.

As the connection is aborted, when i connect to ssl i searched for possible errors there.

I found this lines in the logfile.
no SSL contexts defined for this server
no SSL drivers defined for this server

I do think this is my main problem, but i don't have any clue how to fix it.
I thank you for your patience reading so much text and maybe helping me now :-)

Greetings Patrick>
Collapse
Posted by Otto Solares on
You could check the package for dotlrn-2.1.0b1 in:

deb http://home.galileo.edu/~solca/dotlrn_beta binary/

It fixes a lot of problems.

Regards,

-otto

Collapse
Posted by Patrick Rebscher on
Hi Otto,

i tested the dotlrn-2.1.0b1 but i have the same problems as with 2.0.3 :-(

Maybe i only need some advice with the SSL capabilities.
How do i create the needed certificates ?
I won't need a CA or something realy secure, because i am just testing everything in a VMWare.

Thank you,

Patrick

Collapse
Posted by Celio Guimaraes on
I would like to report a few minor problems with your beta debian package (which I could solve)
and a major one (for which I have no clue):
1. At the end of the installation when a dialog box  asks for setting  security settings for the database user in the postgres
pg_hba.conf configuration file the command:
su -  postgres -s /bin/sh -c "createlang plpgsql dotlrn"
fails because the dotlrn database was not created.
        I solved the problem issuing the command: su - postgres createdb dotlrn
2. In the same dialog box the command to "restart the .LRN  server with the following command    /etc/init.d/dotlrn  restart "
fails because there are a few errors in the /etc/init.d/dotlrn script :
the DAEMON variable is incorrect, it should be: DAEMON=/usr/sbin/aolserver4-nsd (instead of /usr/sbin/nsd);
the ADDRESS and PORT variables do not reflect previous user settings and remain at the standard localhost and 80 values
After these corrections the aolserver is started OK and the OpenACS browser based installation proceeds OK.

The unsolved problem:
At the end of the browser based OpenACS installation (when lots of database operations are performed)
and the "Installation finished" message is issued, the following message states that:
"The server has been shutdown. Normally  it should come back by itself.... etc":
the server is shutdown: true; but it does not come back by itself and no errors appear in the log.
After issuing the command  /etc/init.d/dotlrn  restart, a few aolserver process instances do appear in the process list
but the browser cannot connect to the aolserver so the last message that says
click here (here is http://127.0.0.1:8000/dotlrn) will lead to an error trying to access the aolserver
(I have run all the tests locally to make sure there was no network interference)

On the other hand, if  you start the standard aolserver issuing: /etc/init.d/aolserver4 start
the browser will  load the standard aolserver page: "Welcome to your New Home in Cyberspace"
Celio

Collapse
Posted by Otto Solares on
I'll fix 1. & 2. ASAP.

With the unsolved problem I must say that the OpenACS installer assumes people is using daemontools so when the installer shutdown the server it will come up automatically (which is a function of daemontools).  In the debian dotlrn package we don't use daemontools so I'll modify the installer to reflect the fact that people must manually start the server again.

/etc/init.d/aolserver4 is the init script from the aolserver4 package and may collide with the dotlrn one, I'll figure out a solution or warn the user about it.

I'll post a revised version today, thank you for the support.

Collapse
Posted by Otto Solares on
You can create certificates with the mkcert tool:

http://home.galileo.edu/~obonilla/software/

And a working SSL configuration in the .tcl config file.

Collapse
Posted by Celio Guimaraes on
Otto:
Have you posted the revised version?
Celio
Collapse
Posted by Otto Solares on
Yep.  I removed the old packages, the new dotlrn package is here:

deb http://home.galileo.edu/~solca/dotlrn/ binary/
deb-src http://home.galileo.edu/~solca/dotlrn/ source/

Please test it, report back _ANY_ problem.  I am pretty sure this one is almost _debian_repository_ quality.

Collapse
Posted by Celio Guimaraes on
After creating the dotlrn database with owner www-data the package tries to create again the postgres user www-data and then exits after these output messages:

Creating config file /etc/aolserver4/dotlrn-db.tcl with new version
spawn su - postgres -s /bin/sh -c createuser -A -D -P -E -q www-data

Collapse
Posted by Celio Guimaraes on
Despite the error message in my post yesterday,
I successfully installed dotlrn. Thanks Otto!
What I did (for those who may have found installation problems):
1. apt-get --purge remove aolserver4 (it will also purge and remove a previous dotlrn installation)
if a previous installation try failed you should drop the postgres dotlrn  database and user:
  su - postgres dropdb dotlrn
  su - postgres dropuser www-data
2. apt-get install dotlrn
    I did a localhost installation on port 8000
    (for a network installation you'll have to edit
      the postgres config file pg_hba.conf, as stated in
      the proper dialog box)
3.After the command that tries to create again the database
user www-data, start the dotlrn aolserver as stated:
      /etc/init.d/dotlrn start
4.In your browser point to http://localhost:8000/
You will get the web based dotlrn installation page.
After the dotlrn database filling process, the dotlrn aolserver shutsdown and you have to restart it as above
5. set your browser URL to:
http://localhost:8000/dotlrn
and you will get the dotlrn login page
Collapse
Posted by Otto Solares on
Yes, the problem you were seeing was the user/database been lying around and the installer assumes they doesn't exists.  I would never add any code to drop the user/database as that could lead to trouble.  I would add code to properly detect the database and proceed without errors.  Your feedback have been very useful, thanks!

PS.  Maybe you could contribute a portuguese translation to the installer... :)

Collapse
Posted by Patrick Rebscher on
Hi Otto,

i recognized, that your server is pretty busy. I could offer you another mirror. It is a server at the University of Mannheim(Germany). It has 100MBit and plenty of power/space. You can e-mail me at hedoth[at]gmx.net

Greetings
Patrick

Collapse
Posted by Robert Taylor on
hi.

apt update failed to fetch as the server refused connection.

does anyone have a mirror?

thx!

Collapse
Posted by Talli Somekh on
community norms are to use real names in these forums.

talli

Collapse
Posted by Robert Taylor on
Done.

Bad habit of signing up for a billion other forums ...

For anyones info, the server hosting the deb's is down for hardware upgrades and will return after January 1.

Thanks Otto and gang for providing resources, packaging, code, etc.

Collapse
Posted by Jade Rubick on
Otto, would you mind posting how the packages are built?

Since Debian packages can be used for Debian and Fedora, we get very good coverage with these. If you could document how this is done, then we could move towards making this the default method of installation.

Collapse
Posted by Otto Solares on
You mean building from the source package or how to create a debian package (debianize)?

I simply build the package with:

cd source_dir
dpkg-buildpackage -rfakeroot

To build the package you need:

apt-get build-dep dotlrn
apt-get install build-essential fakeroot

The hard part is debianize the package which is better covered  somewhere in the debian's developer corner:

http://www.debian.org/devel/

Hope that helps.

Collapse
Posted by Patrick Rebscher on
Hello,

i offered a Mirror and Otto agreed, so here it is.

deb http://www.fim.uni-mannheim.de/dotlrn/ binary/
deb-src http://www.fim.uni-mannheim.de/dotlrn/ source/

Patrick
Collapse
42: postgresql socket problem (response to 1)
Posted by Jeremy Monnet on
Hi all,

I've just tried that package, and it works fine, except one problem I also had with a manual install : aolserver looks for the postgresql socket in /tmp/.s.PGSQL.5432, while it is created (default debian startup script) in /var/run/postgresql/.s.PGSQL.5432.

I'm not sur if it should try and look for the socket anyway : in the logs the network port is specified "Notice: dbdrv: opening database 'postgres::5432:dotlrn'". Does this mean that the host is not entered correctly ?
What I have experienced with aolserver is : if the database is on localhost, it will try the socket, if it is another ip address, it will connect via the network. What is the prefered way ?

Thanks for your help !

Jeremy

Collapse
Posted by Eduardo Pérez on
> I've just tried that package, and it works fine, except one
> problem I also had with a manual install : aolserver looks
> for the postgresql socket in /tmp/.s.PGSQL.5432, while it is
> created (default debian startup script) in
> /var/run/postgresql/.s.PGSQL.5432.
>
> I'm not sur if it should try and look for the socket anyway :
> in the logs the network port is specified "Notice: dbdrv:
> opening database 'postgres::5432:dotlrn'". Does this mean
> that the host is not entered correctly ?
> What I have experienced with aolserver is : if the database
> is on localhost, it will try the socket, if it is another ip
> address, it will connect via the network. What is the
> prefered way ?

Could you tell us what Debian packages do you have installed and what packages did you install manually?
Installing most packages from Debian packages is the best idea as upgrades are easier and they work OK from the first time.

Collapse
Posted by Jeremy Monnet on
Everything was installed from apt-get.

I have installed manually dotlrn (last stable version 2.1.1) before knowing there was a debian package. So I deleted everything and reinstalled the debian package of dotlrn and everything from debian packages.

And I have with the debian package now the same socket problem I had when installing from sources. Maybe someone knows how to setup aolserver to specify where the database local socket should be ?
If the database was not running on the same computer, I should have configured an ip address in config.tcl, and it would have been fine from the first time ...

Collapse
45: Ubuntu package of .LRN (response to 1)
Posted by Juan sepulveda on
Hi to everyone I have an error intalling the .lrn.

Firstable I´d like to know if I should install postgresql before the .lrn :

apt-get install dotlrn postgresql or apt-get intall dotlrn( with postgresql installed)

This is the error message that I got trying to install postgres

root@ubuntu:/var/run/postgresql# apt-get install postgresql-7.4
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias... Hecho
Se instalarán los siguientes paquetes NUEVOS:
postgresql-7.4
0 actualizados, 1 se instalarán, 0 para eliminar y 0 no
actualizados.
1 no instalados del todo o eliminados.
Necesito descargar 2584kB de archivos.
Se utilizarán 8360kB de espacio de disco adicional después de
desempaquetar.
Des:1 http://es.archive.ubuntu.com breezy/main postgresql-7.4
1:7.4.8-17ubuntu1 [2584kB]
Descargados 2584kB en 25s (101kB/s)

Preconfigurando paquetes ...
Seleccionando el paquete postgresql-7.4 previamente no seleccionado.
(Leyendo la base de datos ...
69209 ficheros y directorios instalados actualmente.)
Desempaquetando postgresql-7.4 (de
../postgresql-7.4_1%3a7.4.8-17ubuntu1_i386.deb) ...
Configurando dotlrn (2.1.0beta1-4) ...
spawn su - postgres -s /bin/sh -c createuser -A -D -P -E -q www-data
Enter password for new user:
Enter it again:
createuser: could not connect to database template1: could not
connect
to server: No such file or directory
Is the server running locally and accepting
connections on Unix domain socket
"/var/run/postgresql/.s.PGSQL.5432"?
createdb: could not connect to database template1: could not connect
to
server: No such file or directory
Is the server running locally and accepting
connections on Unix domain socket
"/var/run/postgresql/.s.PGSQL.5432"?
dpkg: error al procesar dotlrn (--configure):
el subproceso post-installation script devolvió el código de salida
de
error 1
Configurando postgresql-7.4 (7.4.8-17ubuntu1) ...
Creating new cluster (configuration: /etc/postgresql/7.4/main, data:
/var/lib/postgresql/7.4/main)...
Moving configuration file /var/lib/postgresql/7.4/main/pg_hba.conf
to
/etc/postgresql/7.4/main...
Moving configuration file /var/lib/postgresql/7.4/main/pg_ident.conf
to
/etc/postgresql/7.4/main...
Moving configuration file
/var/lib/postgresql/7.4/main/postgresql.conf
to /etc/postgresql/7.4/main...
Configuring postgresql.conf to use port 5432...
* Starting PostgreSQL 7.4 database server: main The PostgreSQL
server
failed to start. Please check the log
output:/usr/lib/postgresql/7.4/bin/postmaster: para usar SSL, se
deben
activar las conexiones TCP/IP


[fail]

Se encontraron errores al procesar:
dotlrn
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@ubuntu:/var/run/postgresql# apt-get install dotlrn
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias... Hecho
dotlrn ya está en su versión más reciente.
0 actualizados, 0 se instalarán, 0 para eliminar y 0 no
actualizados.
1 no instalados del todo o eliminados.
Necesito descargar 0B de archivos.
Se utilizarán 0B de espacio de disco adicional después de
desempaquetar .
Configurando dotlrn (2.1.0beta1-4) ...
spawn su - postgres -s /bin/sh -c createuser -A -D -P -E -q www-data
Enter password for new user:
Enter it again:
createuser: could not connect to database template1: could not
connect
to server: No such file or directory
Is the server running locally and accepting
connections on Unix domain socket
"/var/run/postgresql/.s.PGSQL.5432"?
createdb: could not connect to database template1: could not connect
to
server: No such file or directory
Is the server running locally and accepting
connections on Unix domain socket
"/var/run/postgresql/.s.PGSQL.5432"?
dpkg: error al procesar dotlrn (--configure):
el subproceso post-installation script devolvió el código de salida
de
error 1
Se encontraron errores al procesar:
dotlrn
E: Sub-process /usr/bin/dpkg retuon Oct 10 13:14:36 BST 2005 i686
GNU/Linux

I know that is long but this is what I got. ¿¿any help??

Collapse
Posted by Otto Solares on
Do you have your postgresql server in the same box with .LRN? That should work.
Collapse
Posted by Carl Robert Blesius on
Noticed the site is down. What is the status of the Debian installer?
Collapse
Posted by Rocael Hernández Rizzardini on
check this:
http://openacs.org/forums/message-view?message_id=350859

soon we'll update the installer.