Home
The Toolkit for Online Communities
17614 Community Members, 1 member online, 2918 visitors today
Log In Register
OpenACS Home : Forums : .LRN Q&A : Problem getting WYSIWYG editor with richtext widget running : One Message

Forum .LRN Q&A: Re: Problem getting WYSIWYG editor with richtext widget running

Collapse
Posted by xx xx on
Hi Jon,

Your code works fine when pasted in a blank document.
I don't get html parsing errors, although I cannot check your "uos_add_insert" page.

You may need to call <master src="blank-master"> and change rows to 6 or more to see the htmlarea. Try in a blank document by calling <master src="blank-master"><formtemplate id="new_uos"></formtemplate>

Did you check the allowedTag and allowedAttribute parameters in the kernel? Do you have code that is "older". Is htmlarea actually available (check blank-master). Is javascript not blocked? ....

BTW, {B I URL} buttons are from the richtext widget not from htmlarea.

[quote]
You may need to call <master src="blank-master"> and change rows to 6 or more to see the htmlarea. Try in a blank document by calling <master src="blank-master"><formtemplate id="new_uos"></formtemplate>
[/quote]

... blank-master isn't defined in my package. Am I supposed to derive it from somewhere else? I've tried setting a field to the size of the screen but that doesn't change it for me.

[quote]
Did you check the allowedTag and allowedAttribute parameters in the kernel? Do you have code that is "older". Is htmlarea actually available (check blank-master). Is javascript not blocked? ....
[/quote]

Currently AllowedAttribute is set to "href" for me, and AllowedTag is: B I P A LI
Javascript shouldn't be blocked, as I have other forms utilizing it (just simple form validation), so it shouldn't be that.

I'm just wondering about what you've mentioned about html being in blank-master. Do I need to download the zip file of htmlarea for this, or ?

Thanks for your help.
Cheers, Jon

Forget my previous post, I've included blank-master from my main dotlrn/www/ directory and it shows up perfectly.

*smacks forehead* here's to my own incredulous incompetency :)

Thanks again!