Home
The Toolkit for Online Communities
17606 Community Members, 0 members online, 2641 visitors today
Log In Register
OpenACS Home : Forums : OpenACS Q&A : + openacs 5.4.3 debian/ubuntu packages released : One Message

Forum OpenACS Q&A: installation completed as per the xowiki/debian instructions

Collapse
Posted by Kenneth Wyrick on
I added the dotlrn/openacs to the et/apt/sources.list

then did apt-get update which loaded a few more packages
i was worried about the other two etch security lines that i see in the etc/apt/sources.list but they did not seem to get in the way

Next I copied the postgresql8.3 from the xowiki/debian doc and it installed postgres nicely.

Next I copied the apt-get install dotlrn from the xowiki/debian doc and it intalled the openacs and referred me to the install: http://localhost:8000

I filled out the Installation forum in the browser and it installed all the packages and dotlrn.

It said it should re-start the server in a minute or so but it didn't...it's been about 7min's now and it's still not started.

I then referred back to your documentation to find: a small doc (/usr/share/doc/openacs/README.daemontools) to help control openacs|dotlrn under daemontools. Which I looked for but I did not find it. The /usr/share/doc is there but no /openacs.

So now I'm off to restart the server.

Will you please update the xowiki/debian install to include:
1. installing etch with the debian-40ra-i386 netinst iso (161.5mb)
2. the apt-get -u blah blah after the apt-get update

then create the openacs/README.daemontools document in place for the installation????

Collapse
Posted by Kenneth Wyrick on
As I'm looking through this file it says:
read comments in file:
# /var/lib/aolserver/service0/packages/etc/daemontools/run

the aolserver folder (above) does not exist ... I did find a dotlrn folder in the /var/lib but it only has an empty /content-repository-content-files

So now I'm looking at the end of the log (included below)
[17/Nov/2008:08:41:27][7011.3057699728][-conn:0-] Notice:

Installed Zen Theme, version 2.4.1.

[17/Nov/2008:08:41:27][7011.3057699728][-conn:0-] Notice:

Package enabled.
[17/Nov/2008:08:41:27][7011.3057699728][-conn:0-] Notice: apm_invoke_callback_proc: invoking callback after-install with command theme_z$
[17/Nov/2008:08:41:28][7011.3057699728][-conn:0-] Notice:

Mounted an instance of the package at /theme-zen

[17/Nov/2008:08:41:28][7011.3057699728][-conn:0-] Notice: apm_invoke_callback_proc: invoking callback after-instantiate with command dot$
[17/Nov/2008:08:41:29][7011.3057699728][-conn:0-] Notice: reading /usr/share/dotlrn/packages/acs-admin/catalog/acs-admin.en_US.ISO-8859-$
[17/Nov/2008:08:41:29][7011.3057699728][-conn:0-] Notice: Loading messages in file /usr/share/dotlrn/packages/acs-admin/catalog/acs-admi$
[17/Nov/2008:08:41:30][7011.3057699728][-conn:0-] Notice: reading /usr/share/dotlrn/packages/acs-authentication/catalog/acs-authenticati$
[17/Nov/2008:08:41:30][7011.3057699728][-conn:0-] Notice: Loading messages in file /usr/share/dotlrn/packages/acs-authentication/catalog$
[17/Nov/2008:08:41:30][7011.3057699728][-conn:0-] Notice: reading /usr/share/dotlrn/packages/acs-kernel/catalog/acs-kernel.en_US.ISO-885$
[17/Nov/2008:08:41:30][7011.3057699728][-conn:0-] Notice: Loading messages in file /usr/share/dotlrn/packages/acs-kernel/catalog/acs-ker$
[17/Nov/2008:08:41:33][7011.3057699728][-conn:0-] Notice: reading /usr/share/dotlrn/packages/acs-tcl/catalog/acs-tcl.en_US.ISO-8859-1.xm$
[17/Nov/2008:08:41:33][7011.3057699728][-conn:0-] Notice: Loading messages in file /usr/share/dotlrn/packages/acs-tcl/catalog/acs-tcl.en$
WARNING: nonstandard use of \\ in a string literal
LINE 4: 'Multiple definitions of ad_page_contract filter \\"...
^
HINT: Use the escape string syntax for backslashes, e.g., E'\\'.
WARNING: nonstandard use of \\ in a string literal
LINE 4: 'The -requires element \\"%element%\\" has a comma i...
^
HINT: Use the escape string syntax for backslashes, e.g., E'\\'.
WARNING: nonstandard use of \\ in a string literal
LINE 4: 'The -requires element \\"%element%\\" has too many ...
^
HINT: Use the escape string syntax for backslashes, e.g., E'\\'.
WARNING: nonstandard use of \\ in a string literal
LINE 4: 'The flag name \\"%name%\\" is reserved for ad_page_...
^
HINT: Use the escape string syntax for backslashes, e.g., E'\\'.
WARNING: nonstandard use of \\ in a string literal
LINE 4: 'Validation \\"%key%\\" complained'
^
HINT: Use the escape string syntax for backslashes, e.g., E'\\'.
WARNING: nonstandard use of \\ in a string literal
LINE 4: '%name% is not in the range \\[%min%, %max%\\]'
^
HINT: Use the escape string syntax for backslashes, e.g., E'\\'.
[17/Nov/2008:08:41:35][7011.3057699728][-conn:0-] Notice: reading /usr/share/dotlrn/packages/acs-templating/catalog/acs-templating.en_US$
[17/Nov/2008:08:41:35][7011.3057699728][-conn:0-] Notice: Loading messages in file /usr/share/dotlrn/packages/acs-templating/catalog/acs$
[17/Nov/2008:08:41:37][7011.3057699728][-conn:0-] Notice: reading /usr/share/dotlrn/packages/search/catalog/search.en_US.ISO-8859-1.xml $
[17/Nov/2008:08:41:37][7011.3057699728][-conn:0-] Notice: Loading messages in file /usr/share/dotlrn/packages/search/catalog/search.en_U$
[17/Nov/2008:08:41:47][7011.3053497232][-sched:idle0-] Notice: starting
[17/Nov/2008:08:41:47][7011.3083544768][-main-] Notice: nsmain: AOLserver/4.5.0 stopping
[17/Nov/2008:08:41:47][7011.3083544768][-main-] Notice: driver: stopping: nssock
[17/Nov/2008:08:41:47][7011.3061902224][-nssock:driver-] Notice: exiting
[17/Nov/2008:08:41:47][7011.3057699728][-conn:0-] Notice: exiting: shutdown pending
[17/Nov/2008:08:41:47][7011.3083544768][-main-] Notice: sched: shutdown pending
[17/Nov/2008:08:41:47][7011.3073629072][-sched-] Notice: sched: shutdown started
[17/Nov/2008:08:41:47][7011.3073629072][-sched-] Notice: sched: waiting for event threads...
[17/Nov/2008:08:41:47][7011.3053497232][-sched:idle0-] Notice: exiting
[17/Nov/2008:08:41:47][7011.3073629072][-sched-] Notice: sched: shutdown complete
[17/Nov/2008:08:41:47][7011.3083544768][-main-] Notice: driver: stopped: nssock
[17/Nov/2008:08:41:47][7011.3061902224][-shutdown-] Notice: nslog: closing '/usr/share/dotlrn/log/dotlrn.log'
[17/Nov/2008:08:41:47][7011.3083544768][-main-] Notice: nsmain: AOLserver/4.5.0 exiting
[17/Nov/2008:08:32:25][6644.3083577536][-main-] Notice: nsmain: AOLserver/4.5.0 starting
[17/Nov/2008:08:32:25][6644.3083577536][-main-] Notice: nsmain: security info: uid=33, euid=33, gid=33, egid=33
[17/Nov/2008:08:32:25][6644.3083577536][-main-] Notice: nsmain: max files: FD_SETSIZE = 1024, rl_cur = 1024, rl_max = 1024
[17/Nov/2008:08:32:25][6644.3083577536][-main-] Notice: fastpath[main]: mapped GET /
[17/Nov/2008:08:32:25][6644.3083577536][-main-] Notice: fastpath[main]: mapped HEAD /
[17/Nov/2008:08:32:25][6644.3083577536][-main-] Notice: fastpath[main]: mapped POST /
[17/Nov/2008:08:32:25][6644.3083577536][-main-] Notice: adp[main]: mapped GET /*.adp
[17/Nov/2008:08:32:25][6644.3083577536][-main-] Notice: adp[main]: mapped HEAD /*.adp
[17/Nov/2008:08:32:25][6644.3083577536][-main-] Notice: adp[main]: mapped POST /*.adp
[17/Nov/2008:08:32:25][6644.3083577536][-main-] Notice: adp[main]: mapped GET /*.html
[17/Nov/2008:08:32:25][6644.3083577536][-main-] Notice: adp[main]: mapped HEAD /*.html
[17/Nov/2008:08:32:25][6644.3083577536][-main-] Notice: adp[main]: mapped POST /*.html
[17/Nov/2008:08:32:25][6644.3083577536][-main-] Notice: modload: loading '/usr/lib/aolserver4/bin/nssock.so'
[17/Nov/2008:08:32:25][6644.3083577536][-main-] Notice: modload: loading '/usr/lib/aolserver4/bin/nslog.so'
[17/Nov/2008:08:32:25][6644.3083577536][-main-] Notice: nslog: opened '/var/log/aolserver4/aolserver4.log'
[17/Nov/2008:08:32:25][6644.3083577536][-main-] Notice: modload: loading '/usr/lib/aolserver4/bin/nscgi.so'
[17/Nov/2008:08:32:25][6644.3083577536][-main-] Warning: nscgi: no such interps section: ns/interps/cgiinterps
[17/Nov/2008:08:32:25][6644.3083577536][-main-] Notice: nscgi: GET /cgi-bin -> /usr/lib/cgi-bin
[17/Nov/2008:08:32:25][6644.3083577536][-main-] Notice: nscgi: POST /cgi-bin -> /usr/lib/cgi-bin
[17/Nov/2008:08:32:25][6644.3083577536][-main-] Notice: nscgi: GET /*.py
[17/Nov/2008:08:32:25][6644.3083577536][-main-] Notice: nscgi: POST /*.pl
[17/Nov/2008:08:32:25][6644.3083577536][-main-] Notice: nscgi: POST /*.py
[17/Nov/2008:08:32:25][6644.3083577536][-main-] Notice: modload: loading '/usr/lib/aolserver4/bin/nsperm.so'
[17/Nov/2008:08:32:25][6644.3083577536][-main-] Notice: conf: [ns/server/main]enabletclpages = 0
[17/Nov/2008:08:32:27][6644.3083577536][-main-] Notice: XOTcl version 1.6.1 loaded
[17/Nov/2008:08:32:28][6644.3083577536][-main-] Notice: nsmain: AOLserver/4.5.0 running
[17/Nov/2008:08:32:28][6644.3083577536][-main-] Notice: nsmain: security info: uid=33, euid=33, gid=33, egid=33
[17/Nov/2008:08:32:28][6644.3083577536][-main-] Notice: driver: starting: nssock
[17/Nov/2008:08:32:28][6644.3073661840][-sched-] Notice: sched: starting
[17/Nov/2008:08:32:28][6644.3073239952][-nssock:driver-] Notice: starting
[17/Nov/2008:08:32:28][6644.3073239952][-nssock:driver-] Error: nssock: failed to listen on 127.0.0.1:80: Permission denied
[17/Nov/2008:08:32:28][6644.3073239952][-nssock:driver-] Notice: exiting
[17/Nov/2008:08:32:28][6644.3083577536][-main-] Fatal: could not start drivers
So now I will continue configuring and the dotlrn, adding packages and doing things like getting it under cvs and trying to backup my http://caltek.net and restoring it here so I have a local instance.

I also plan to work on going through the ubuntu and the fedora which should work on the centOS system I have access to.

Thanks for any help you can provide me and any specific testing that you would like to see please feel free to let me know.

cheers!
ps I still would like to know which debian install medium you would use for installation...maybe the etch is the best one for now...i will test it again on another box starting today unless you give me a better source to use.

Hi Kenneth,

Next time, only a post for all please! :)

Ok, the readme for daemontools is on:

* /usr/share/doc/openacs/README.daemontools on openacs package.
* /usr/share/doc/dotlrn/README.daemontools on dotlrn package.

It's normal that you could not find the openacs one on the dotlrn package ;-)

For a new debian install, I use the etch netinst cd, and then (if i need to) upgrade to testing or sid using the procedure I told you before. Another way is to use the testing installer directly, but it may contain bugs: http://www.us.debian.org/devel/debian-installer/

About your problems with gdm, it should be a problem with the driver xorg is loading, but as it's a debian problem (not related with dotlrn|openacs), I think this is not the place to discuss it...

When the install ends, and the installer says openacs|dotlrn will be restarted in a time, it kills the process hoping that it will be restarted by daemontools or whatever... but it doesn't happens if you haven't configured it that way, so you have to manually do /etc/init.d/openacs|dotlrn start.

Thanks for the huge testing work!

-- Héctor

Collapse
Posted by Kenneth Wyrick on
I downloaded and installed the testing netinst iso from your link above.
I only installed the debian core package by un selecting the Desktop at the top of the list.
The install went smoothly and when it was done and the computer rebooted I installed lynx and proceeded to goto http://openacs.org/xowiki/debian to get the http://debian.adenu.ia.uned.es/apt sid main so i could type it into the /etc/apt/source.list using pico.
I did the update and then I installed the apt-get install postgresql-8.3
Next I installed the apt-get install openacs
I noticed it installed x11, aolserver4 and other things including the OpenACS.
When it finished I did a ifconfig to determine the ip address of the ethernet carddid lynx 127.0.0.1:8000, it opened the Installtion page and I filled it out replacing the http://localhost with http://ipaddress but I didn't think about testing it until right now and I could not reach it from the other computer. So I figure it should work and maybe the system needs to be rebooted. So since I will not be able to edit this post I will continue it once i've done more.
The above instance comes up but crashes as soon as i access it and login to it.

The next thing to do, in the instructions, is to setup the keepalive using svn which is not installed by default and I can not find where to get it so it can be installed.

I searched using synaptics and also searched the web for it.

Kenneth,

1. Regarding the crashing, can you provide more detail? Are you saying there is a page load error or aolserver stops running or? Any clues in the openacs error log?

2. If memory serves well, you can search the debian package system from a root shell by typing 'apt-cache search svn' and then apt-get install the svn package you are looking for (assuming it's found).

cheers,

Torben

Hi Kenneth,

Maybe you mean svc (from daemontools package) for keepalive, instead of svn (subversion)?

In that case, i wrote the neccesary steps to configure it with dotlrn|openacs on the readme you can find on /usr/share/dotlrn|openacs/README.daemontools. In short, you have to install the daemontools package (on debian sid, and on several ubuntu versions: http://packages.ubuntu.com/search?keywords=daemontools) and then:

1) Change the "StartDaemon" value to "no" on /etc/default/dotlrn|openacs to disable the init.d script.

2) Stop the daemon (/etc/init.d/dotlrn|openacs stop)

3) Link daemontools dotlrn|openacs script ( ln -s /usr/share/dotlrn|openacs/etc/daemontools /etc/service/dotlrn|openacs ).

Cheers, Héctor

Hi Hector,

Thanks for such a quick reply.

Yes svc is what I ment to type.

I went to the link for installing daemontools package but didn't know which one to choose so

I tried doing apt-get install daemontools
it Suggested package daemontools-run runit and
installed daemontools from a 65.4kB archive.

It got http://ftp.us.debian.org lenny/main daemontools 1:0.76-3 [65.4kB]
it unpacked daemontools (from .../daemontools_1%3a0.76-3_i386.deb) ...
Processed triggers fro man-db
setup daemontools (1:0.76-3)

I edited the StartDaemon for openacs to disable the init.d script as per 1) above

I stopped the daemon as per 2) above

1 then did 3) ln -s /usr/share/openacs/etc/daemontools /etc/openacs/daemontools which I'm not completely sure that i did it right since you wrote /etc/service/openacs and since it was not there i used /etc/openacs/daemontools

and when I tried to access it the following is what i got:
Failed to Connect

The connection was refused when attempting to contact 192.168.2.17:8000.

Though the site seems valid, the browser was unable to establish a connection.

I've just rebooted the system and will try it again.

Collapse
Posted by Kenneth Wyrick on
I've done another install and found the /usr/share/doc/dotlrn/README.daemontools:
Now you can control the dotlrn service using the svc command:
* To start the service: svc -u /etc/service/dotlrn.
* To stop the service: svc -d /etc/service/dotlrn.
* To restart the service: svc -t /etc/service/dotlrn.

but the /etc/service/dotlrn does not exist. what does exist is the /etc/dotlrn

debian:/etc/dotlrn# ls
analog.cfg backup.sh config.tcl daemontools deploy.sh install keepalive
debian:/etc/dotlrn# svc -t /etc/dotlrn
svc: warning: unable to control /etc/dotlrn: file does not exist
debian:/etc/dotlrn# svc -t /etc/dotlrn/daemontools/
svc: warning: unable to control /etc/dotlrn/daemontools/: file does not exist
debian:/etc/dotlrn#

why do i not have a /service/dotlrn? are the docs correct and i did something wrong? please tell me what to do to get it working?

Hi Kenneth,

You have to install the daemontools-run package too, which creates the /etc/service directory, used by daemontools to launch services.

You can get it from the official debian repository where you found the daemontools package.

Cheers, Héctor

I apt-get installed daemontools-run and it installed smoothly.
my next steps were:
debian:/etc/service# /etc/init.d/dotlrn stop
Stopping web server: dotlrn.
debian:/etc/service# ln -s /usr/share/dotlrn/etc/daemontools /etc/service/dotlrn
debian:/etc/service# svc -d /etc/service/dotlrn
debian:/etc/service# svc -u /etc/service/dotlrn
debian:/etc/service# svc -d /etc/service/dotlrn
debian:/etc/service# /etc/init.d/dotlrn stop
Stopping web server: dotlrn.
debian:/etc/service# svc -d /etc/service/dotlrn
debian:/etc/service#
and the instance stayed up the whole time resolving to: http://localhost:8000 while I was trying to stop it.
note....
the /etc/aolserver4/aolserver4.tcl file:
set hostname localhost
set address 0.0.0.0
and
the /etc/dotlrn/config.tcl file:
set hostname localhost
set address 192.168.1.112

what am i missing?
also please point me to the docs for setting it to a public ip, like dave referred to earlier in this thread. thank!

Hi Kenneth,

To config the instance to listen on a different IP than 127.0.0.1, you only have to edit the /etc/openacs|dotlrn/config.tcl file and change the following parameters to fit your needs:

set httpport Your port
set hostname Your hostname
set address your public IP

Then restart the service and that's it!

About the problem with svc, maybe is related to the symbolic links you did before. Please, purge the dotlrn package and reinstall it:

# apt-get remove --purge dotlrn
# apt-get install dotlrn

I also did a fix on the package's init script, which isn't properly evaluating the /etc/default/dotlrn file, so reinstalling is recommended anyway ;-).

-- Héctor

debian:/home/student# apt-get remove --purge dotlrn
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
xotcl aolserver4-nssha1 aolserver4-doc wwwconfig-common tdom tcllib
aolserver4 tcl8.4 aolserver4-core aolserver4-nspostgres aolserver4-nscache
aolserver4-xotcl tclthread
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
dotlrn*
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 105MB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database ... 129118 files and directories currently installed.)
Removing dotlrn ...
Stopping web server: dotlrn.
Purging configuration files for dotlrn ...
dpkg - warning: while removing dotlrn, directory `/var/log/aolserver4/dotlrn' not empty so not removed.
debian:/home/student# apt-get install dotlrn
Reading package lists... Done
Building dependency tree
Reading state information... Done
Suggested packages:
postgresql
The following NEW packages will be installed:
dotlrn
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/24.9MB of archives.
After this operation, 105MB of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
dotlrn
Install these packages without verification [y/N]? y
Preconfiguring packages ...
Selecting previously deselected package dotlrn.
(Reading database ... 114968 files and directories currently installed.)
Unpacking dotlrn (from .../archives/dotlrn_2.4.1_all.deb) ...
Setting up dotlrn (2.4.1) ...
Reloading PostgreSQL 8.3 database server: main.
Starting web server: dotlrn.
debian:/home/student#

Stopping web server: dotlr
debian:/etc/default# ln -s /usr/share/dotlrn/etc/daemontools /etc/service/dotlrn
debian:/etc/default#

svc -u /etc/service/dotlrn
svc -d /etc/service/dotlrn
both worked even though it took it more than a minute to come up.

I then edited the /etc/dotlrn/config.tcl
set hostname hostname
set address 0.0.0.0
and the same thing happened like before. When it finally came up it let me access the http://192.168.1:8000 but when i entered my username and password it was hosed.

I've installed Debian Jan Testing on another computer and will go through the whole process again, now.

thanks.

Hi Kenneth,

You seem to forgot to edit the /etc/default file to avoid the init script to be used instead of the daemontools.

Please, can you post the log when trying to access with your username and password (/var/log/aolserver/dotlrn/error.log)?

-- Héctor

debian:/etc/default# cat dotlrn
### dotLRN default file

## Set this to "no" to disable the /etc/init.d/dotlrn script.
StartDaemon="no"
debian:/etc/default#

---------------------------
I did edit the default dotlrn

Looking through the error log i found the following:
[13/Jan/2009:13:49:41][3739.3083434176][-main-] Notice: nsmain: AOLserver/4.5.0 running
[13/Jan/2009:13:49:41][3739.3083434176][-main-] Notice: nsmain: security info: uid=33, euid=33, gid=33, egid=33
[13/Jan/2009:13:49:41][3739.3073518480][-sched-] Notice: sched: starting
[13/Jan/2009:13:49:41][3739.3083434176][-main-] Notice: driver: starting: nssock
[13/Jan/2009:13:49:41][3739.3031853968][-nssock:driver-] Notice: starting
[13/Jan/2009:13:49:41][3739.3031853968][-nssock:driver-] Notice: nssock: listening on 192.168.1.112:8000
[13/Jan/2009:13:50:11][3739.3027651472][-sched:idle0-] Notice: starting
[13/Jan/2009:14:04:24][3739.3023448976][-sched:idle1-] Notice: starting
[13/Jan/2009:14:05:24][3739.3023448976][-sched:22-] Notice: dbdrv: opening database 'postgres:localhost:5432:dotlrn'
[13/Jan/2009:14:05:24][3739.3023448976][-sched:22-] Notice: Opening dotlrn on localhost
[13/Jan/2009:14:05:24][3739.3023448976][-sched:22-] Notice: Ns_PgOpenDb(postgres): Openned connection to localhost:5432:d$
[13/Jan/2009:14:10:14][3739.3083434176][-main-] Notice: nsmain: AOLserver/4.5.0 stopping
[13/Jan/2009:14:10:14][3739.3083434176][-main-] Notice: driver: stopping: nssock
[13/Jan/2009:14:10:14][3739.3031853968][-nssock:driver-] Notice: exiting
[13/Jan/2009:14:10:14][3739.3083434176][-main-] Notice: sched: shutdown pending
[13/Jan/2009:14:10:14][3739.3044461456][-conn:2-] Notice: exiting: shutdown pending
[13/Jan/2009:14:10:14][3739.3040258960][-conn:3-] Notice: exiting: shutdown pending
[13/Jan/2009:14:10:14][3739.3036056464][-conn:4-] Notice: exiting: shutdown pending
[13/Jan/2009:14:10:14][3739.3052866448][-conn:0-] Notice: exiting: shutdown pending
[13/Jan/2009:14:10:14][3739.3048663952][-conn:1-] Notice: exiting: shutdown pending
[13/Jan/2009:14:10:14][3739.3073518480][-sched-] Notice: sched: shutdown started

but didn't see an error from today so I will have to try and recreate it now.

Collapse
Posted by Kenneth Wyrick on
i changed the set address from local host to 0.0.0.0

debian:/etc/dotlrn# pico config.tcl

snip.......
# The hostname and address should be set to actual values.
# setting the address to 0.0.0.0 means aolserver listens on all interfaces
set hostname localhost
set address 0.0.0.0

# Note: If port is privileged (usually < 1024), OpenACS must be
# started by root, and, in AOLserver 4, the run script have a
# '-b address' flag which matches the address according to settings (above)

set server "dotlrn"
set servername "dotLRN"

set serverroot "/usr/share/${server}"
set pidfile /var/run/aolserver4/${server}.pid

---------------------------------------------

debian:/etc/dotlrn# ifconfig
eth0 Link encap:Ethernet HWaddr 00:02:a5:7d:49:ba
inet addr:192.168.1.112 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::202:a5ff:fe7d:49ba/64 Scope:Link

It worked this time. I'm accessing the dotlrn instance on the local ip address (above)

I'm going to another machine to access it....and I was able to access and login successfully to this instance from another machine on the local network.
that closes this chapter.

I will make a separate post for the other 2 or 3 items on my list. setting up cvs to load packages and do back-ups

OK. I got excited and spoke a bit too quick. Now it's back to bring up the login screen but not allowing us to do anything else. In particular register. The following is the log from when it worked to when it didn't:

Setup your own web ba16/Jan/2009:19:07:56][4468.3083184320][-main-] Notice: ns_register_proc GET /finish-component-element* rp_invoke_proc {0$
[16/Jan/2009:19:07:56][4468.3083184320][-main-] Notice: ns_register_proc POST /finish-component-element* rp_invoke_proc {$
[16/Jan/2009:19:08:00][4468.3083184320][-main-] Notice: nsmain: AOLserver/4.5.0 running
[16/Jan/2009:19:08:00][4468.3083184320][-main-] Notice: nsmain: security info: uid=33, euid=33, gid=33, egid=33
[16/Jan/2009:19:08:00][4468.3074554768][-sched-] Notice: sched: starting
[16/Jan/2009:19:08:00][4468.3083184320][-main-] Notice: driver: starting: nssock
[16/Jan/2009:19:08:00][4468.3031493520][-nssock:driver-] Notice: starting
[16/Jan/2009:19:08:00][4468.3031493520][-nssock:driver-] Notice: nssock: listening on 0.0.0.0:8000
[16/Jan/2009:19:08:36][4468.3027291024][-sched:idle0-] Notice: starting
[16/Jan/2009:19:08:45][4468.3023088528][-sched:idle1-] Notice: starting
[16/Jan/2009:19:09:20][4468.3052506000][-conn:0-] Notice: random: generating 1 seed
[16/Jan/2009:19:09:45][4468.3027291024][-sched:13-] Notice: dbdrv: opening database 'postgres:localhost:5432:dotlrn'
[16/Jan/2009:19:09:45][4468.3027291024][-sched:13-] Notice: Opening dotlrn on localhost
[16/Jan/2009:19:09:45][4468.3027291024][-sched:13-] Notice: Ns_PgOpenDb(postgres): Openned connection to localhost:5432:d$
[16/Jan/2009:20:32:23][4468.3018886032][-conn:5-] Notice: encoding: loaded: iso8859-1
Tcl_SetBooleanObj called with shared object
[16/Jan/2009:20:32:28][4830.3083647168][-main-] Notice: nsmain: AOLserver/4.5.0 starting
[16/Jan/2009:20:32:28][4830.3083647168][-main-] Notice: nsmain: security info: uid=33, euid=33, gid=33, egid=33
[16/Jan/2009:20:32:28][4830.3083647168][-main-] Notice: nsmain: max files: FD_SETSIZE = 1024, rl_cur = 1024, rl_max = 1024
[16/Jan/2009:20:32:28][4830.3083647168][-main-] Notice: encoding: loaded: utf-8
[16/Jan/2009:20:32:28][4830.3083647168][-main-] Notice: fastpath[dotlrn]: mapped GET /
[16/Jan/2009:20:32:28][4830.3083647168][-main-] Notice: fastpath[dotlrn]: mapped HEAD /
[16/Jan/2009:20:32:28][4830.3083647168][-main-] Notice: fastpath[dotlrn]: mapped POST /
[16/Jan/2009:20:32:28][4830.3083647168][-main-] Notice: adp[dotlrn]: mapped GET /*.adp
[16/Jan/2009:20:32:28][4830.3083647168][-main-] Notice: adp[dotlrn]: mapped HEAD /*.adp
[16/Jan/2009:20:32:28][4830.3083647168][-main-] Notice: adp[dotlrn]: mapped POST /*.adp
[16/Jan/2009:20:32:28][4830.3083647168][-main-] Notice: modload: loading '/usr/lib/aolserver4/bin/nssock.so'
[16/Jan/2009:20:32:28][4830.3083647168][-main-] Notice: modload: loading '/usr/lib/aolserver4/bin/nslog.so'
[16/Jan/2009:20:32:28][4830.3083647168][-main-] Notice: nslog: opened '/usr/share/dotlrn/log/dotlrn.log'
[16/Jan/2009:20:32:28][4830.3083647168][-main-] Notice: modload: loading '/usr/lib/aolserver4/bin/nssha1.so'
[16/Jan/2009:20:32:28][4830.3083647168][-main-] Notice: modload: loading '/usr/lib/aolserver4/bin/nscache.so'
[16/Jan/2009:20:32:28][4830.3083647168][-main-] Notice: nscache module version 1.4 server: dotlrn

snip......
....without me doing anything except logging in and trying to register from yet another computer

...the following from the end of the file 2 minutes later and some 5000 lines later of it loading all kinds of stuff

[16/Jan/2009:20:34:25][4830.3083647168][-main-] Notice: Loading packages/lars-blogger/tcl/technorati-init.tcl...
[16/Jan/2009:20:34:25][4830.3083647168][-main-] Notice: Loaded packages/lars-blogger/tcl/technorati-init.tcl.
[16/Jan/2009:20:34:25][4830.3083647168][-main-] Notice: Loading packages/notifications/tcl/reply-sweep-init.tcl...
[16/Jan/2009:20:34:25][4830.3083647168][-main-] Notice: Loaded packages/notifications/tcl/reply-sweep-init.tcl.
[16/Jan/2009:20:34:25][4830.3083647168][-main-] Notice: Loading packages/notifications/tcl/sweep-init.tcl...
[16/Jan/2009:20:34:25][4830.3083647168][-main-] Notice: Loaded packages/notifications/tcl/sweep-init.tcl.
[16/Jan/2009:20:34:25][4830.3083647168][-main-] Notice: Loading packages/oacs-dav/tcl/oacs-dav-init.tcl...
[16/Jan/2009:20:34:25][4830.3083647168][-main-] Notice: OACS-DAV preauth filters loaded on /dav/*
[16/Jan/2009:20:34:25][4830.3083647168][-main-] Notice: Loaded packages/oacs-dav/tcl/oacs-dav-init.tcl.
[16/Jan/2009:20:34:25][4830.3083647168][-main-] Notice: Loading packages/rss-support/tcl/rss-generation-init.tcl...
[16/Jan/2009:20:34:25][4830.3083647168][-main-] Notice: Loaded packages/rss-support/tcl/rss-generation-init.tcl.
[16/Jan/2009:20:34:25][4830.3083647168][-main-] Notice: Loading packages/search/tcl/search-init.tcl...
[16/Jan/2009:20:34:25][4830.3083647168][-main-] Notice: Loaded packages/search/tcl/search-init.tcl.
[16/Jan/2009:20:34:25][4830.3083647168][-main-] Notice: Loading packages/xml-rpc/tcl/system-init.tcl...
[16/Jan/2009:20:34:25][4830.3083647168][-main-] Notice: Loaded packages/xml-rpc/tcl/system-init.tcl.
[16/Jan/2009:20:34:25][4830.3083647168][-main-] Notice: Loading packages/xml-rpc/tcl/validator-init.tcl...
[16/Jan/2009:20:34:25][4830.3083647168][-main-] Notice: Loaded packages/xml-rpc/tcl/validator-init.tcl.
[16/Jan/2009:20:34:34][4830.3083647168][-main-] Notice: Loading packages/news/tcl/test/news-db-test-init.tcl...
[16/Jan/2009:20:34:35][4830.3083647168][-main-] Notice: Loaded packages/news/tcl/test/news-db-test-init.tcl.
[16/Jan/2009:20:34:36][4830.3083647168][-main-] Notice: Bootstrap: Done loading OpenACS.
[16/Jan/2009:20:34:36][4830.3083647168][-main-] Notice: Sourcing files for postload...
[16/Jan/2009:20:34:36][4830.3083647168][-main-] Notice: Done.
[16/Jan/2009:20:34:36][4830.3083647168][-main-] Notice: Executing initialization code blocks...
[16/Jan/2009:20:34:36][4830.3083647168][-main-] Notice: Executing initialization code block filters_register in /usr/share$
[16/Jan/2009:20:34:36][4830.3083647168][-main-] Notice: Executing initialization code block procs_register in /usr/share/d$
[16/Jan/2009:20:34:36][4830.3083647168][-main-] Notice: ns_register_proc GET /grades-sheet-csv* rp_invoke_proc {0 0 0 eva$
[16/Jan/2009:20:34:36][4830.3083647168][-main-] Notice: ns_register_proc POST /grades-sheet-csv* rp_invoke_proc {0 0 0 ev$
[16/Jan/2009:20:34:36][4830.3083647168][-main-] Notice: ns_register_proc GET /finish-component-element* rp_invoke_proc {0$
[16/Jan/2009:20:34:36][4830.3083647168][-main-] Notice: ns_register_proc POST /finish-component-element* rp_invoke_proc {$
[16/Jan/2009:20:34:40][4830.3083647168][-main-] Notice: nsmain: AOLserver/4.5.0 running
[16/Jan/2009:20:34:40][4830.3083647168][-main-] Notice: nsmain: security info: uid=33, euid=33, gid=33, egid=33
[16/Jan/2009:20:34:40][4830.3075017616][-sched-] Notice: sched: starting
[16/Jan/2009:20:34:40][4830.3083647168][-main-] Notice: driver: starting: nssock
[16/Jan/2009:20:34:40][4830.3031956368][-nssock:driver-] Notice: starting
[16/Jan/2009:20:34:40][4830.3031956368][-nssock:driver-] Notice: nssock: listening on 0.0.0.0:8000

Hi Kenneth,

It seems that the instance is restarting when you register, but there is no clue for me on the log of why is it doing this way. Does it happens every time you login, or just one time?

-- Héctor

Now the instance does not start automatically. When I do svc -t /etc/service/dotlrn it will stay started for a good while as i use it on the local computer. As soon as i go to another computer, bring up the splash page and try to login it crashes.

I'm wondering if there are any optimizations that could be done to affect this. I'm also wondering if this computer is powerful enough to handle the dotlrn.

MemTotal: 515212 kB
MemFree: 8876 kB
Buffers: 3116 kB
Cached: 87276 kB
SwapCached: 1116 kB
Active: 415588 kB
Inactive: 37292 kB
HighTotal: 0 kB
HighFree: 0 kB
LowTotal: 515212 kB
LowFree: 8876 kB
SwapTotal: 859436 kB
SwapFree: 856140 kB

processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 8
model name : Pentium III (Coppermine)
stepping : 10
cpu MHz : 996.778
cache size : 256 KB

I've also noticed that the /var/log/aolserver4/dotlrn/error.log

starts loading modules which tie up the system and causes it to become unreachable, temporarily.

debian:/var/log/aolserver4/dotlrn# tail error.log
[20/Jan/2009:09:24:32][3112.3083745472][-main-] Notice: ns_register_proc GET /grades-sheet-csv* rp
_invoke_proc {0 0 0 evaluation::generate_grades_sheet {}}
[20/Jan/2009:09:24:32][3112.3083745472][-main-] Notice: ns_register_proc POST /grades-sheet-csv* r
p_invoke_proc {0 0 0 evaluation::generate_grades_sheet {}}
[20/Jan/2009:09:24:32][3112.3083745472][-main-] Notice: ns_register_proc GET /finish-component-ele
ment* rp_invoke_proc {0 0 1 imsld::finish_component_element {}}
[20/Jan/2009:09:24:32][3112.3083745472][-main-] Notice: ns_register_proc POST /finish-component-el
ement* rp_invoke_proc {0 0 1 imsld::finish_component_element {}}
[20/Jan/2009:09:24:38][3112.3083745472][-main-] Notice: nsmain: AOLserver/4.5.0 running
[20/Jan/2009:09:24:38][3112.3083745472][-main-] Notice: nsmain: security info: uid=33, euid=33, gid
=33, egid=33
[20/Jan/2009:09:24:38][3112.3075115920][-sched-] Notice: sched: starting
[20/Jan/2009:09:24:38][3112.3083745472][-main-] Notice: driver: starting: nssock
[20/Jan/2009:09:24:38][3112.3032054672][-nssock:driver-] Notice: starting
[20/Jan/2009:09:24:38][3112.3032054672][-nssock:driver-] Notice: nssock: listening on 0.0.0.0:8000
debian:/var/log/aolserver4/dotlrn# tail error.log
[20/Jan/2009:09:28:28][3112.3044662160][-conn:2-] Warning: adding fs admin portlet to page - fs_adm
in_portlet
[20/Jan/2009:09:28:28][3112.3044662160][-conn:2-] Notice: Added applet:::: dotlrn_fs
[20/Jan/2009:09:28:28][3112.3044662160][-conn:2-] Notice: Added applet:::: dotlrn_forums
[20/Jan/2009:09:28:28][3112.3044662160][-conn:2-] Notice: dotlrn::mount_package: object_type apm_pa
ckage url /dotlrn/clubs/menlo1600/ object_id 5834 instance_name {Menlo 1600} package_type apm_appli
cation package_id 5834 name menlo1600 node_id 5833 directory_p t package_key dotlrn pattern_p t par
ent_id 2149
[20/Jan/2009:09:28:29][3112.3044662160][-conn:2-] Notice: Added applet:::: dotlrn_calendar
[20/Jan/2009:09:28:29][3112.3044662160][-conn:2-] Notice: Added applet:::: dotlrn_faq
[20/Jan/2009:09:28:29][3112.3044662160][-conn:2-] Notice: apm_invoke_callback_proc: invoking callba
ck after-instantiate with command news::install::after_instantiate -package_id 5982
[20/Jan/2009:09:28:29][3112.3044662160][-conn:2-] Notice: Added applet:::: dotlrn_news
[20/Jan/2009:09:28:29][3112.3044662160][-conn:2-] Notice: Added applet:::: dotlrn_static
[20/Jan/2009:09:28:30][3112.3044662160][-conn:2-] Notice: Added applet:::: dotlrn_bm
debian:/var/log/aolserver4/dotlrn#

Collapse
Posted by Kenneth Wyrick on
Dear Hector,

I left the instance up all day yesterday. I hit it and hammered it at the same time from 2 different computers. Once I restarted it at the beginning it did stay up.

I shut it down late last night and fired it back up this morning. After about 10 minutes I went to the other computer and it errored. I tried it again, shortly after that and it was up. So I'm not sure that it will continue to be stable but for now, it's doing what it was intended to do.

thanks.

I was having the same problem with the "Tcl_SetBooleanObj" error. I compiled aolserver 4.5.1 and that didn't solve the error and crashing. I wound up compiling tcl and aolserver from scratch, and my server no longer crashes. Here's exactly the method I used: http://blog.ticketboo.com/2009/02/compile-aolserver-451-on-ubuntu.html
Tony,

Just to keep you posted. We have been in contact with the aolserver maintainer for debian for a while now. Similar incidences have been discussed over at the aolserver list, see e.g. http://article.gmane.org/gmane.comp.web.aolserver/15470.

To cut it short: the issue you encountered has to do with a fundamental conflict between the binary-level coupling of AOLServer core and its modules, on the one hand, and a packaging mechanism with dependency structuring as debian's, on the other hand. In situations of debian package *updates* (aolserver4-core, for instance), you risk running into situations that the module binaries delivered by the debian module packages (aolserver4-nscache etc.) are incompatible with the new core, causing faults of all kind. The inverse (old core, new module) might also occur but is less probable.

Anyways, the debian maintainer came up with a fix to guarantee binary compatibility of core and modules, starting with the upcoming 4.5.1, by playing an elegant trick on the debian packaging infrastructure.

Cheers
//stefan