Home
The Toolkit for Online Communities
16685 Community Members, 0 members online, 2132 visitors today
Log In Register
OpenACS Home : Forums : OpenACS Q&A : External Authentication - LDAP question : One Message

Forum OpenACS Q&A: Re: External Authentication - LDAP question

Collapse
Posted by Chris Grant on
does it have anything to do with the password for the rootdn being a plain text password? i tried to put an empty password in, but came up with the same error...
would i need to encrypt the password?
plain-text password is ok, why you dont try a standard port?, lets say, when you connect to your server using ldapsearch just use "localhost", try to configure ldap and let us know.
Collapse
Posted by Malte Sussdorff on
can you connect via telnet to the port? Try "telnet 127.0.0.1 389" to see what comes up. If you see the LDAP server then we have to look in AOLserver/OpenACS for the problem, otherwise it is something in your setup of LDAP.
Collapse
Posted by Chris Grant on
Rocael, i tried just using localhost when setting up the ldap server, but it gives me the error:
"could not bind to server localhost: Protocol error"

i also tried to telnet to localhost:389 and 127.0.0.1:389 (setting up the ldap server for each case, but each time, it says:
"Temporary failure in name resolution 127.0.0.1:389: Host name lookup failure"
i also tried telnet ldap://127.0.0.1:389 and telnet ldap://localhost:389 without success.
i guess it's the LDAP setup then?

Collapse
Posted by Bruno Mattarollo on

Hey Chris

Try telnet localhost 389 (note the whitespace between localhost and 389) instead of putting the :.

Collapse
Posted by Chris Grant on
thanks Bruno, it worked.
says: "Connected to localhost"

so i guess the problem is not ldap? does anyone have an idea?

Collapse
Posted by Chris Grant on
i changed the slapd.conf file (for openldap) so that it allows binding with LDAPv2. this seemed to do something, because now i get a strange error message:
"error: nsldap: could not open connection to server ldap://localhost" on port 389: Success"
i does anyone know what this means? it still says:
"could not allocate 1 handle from pool ldap" though...
Collapse
Posted by Chris Grant on
hi guys, thanks for all your help! i've managed to get it working now =)